Write a program which reads three integers a, b and c, and prints the number of divisors of c between a and b.
Input
Three integers a, b and c are given in a line separated by a single space.
Output
Print the number of divisors in a line.
Constraints
- 1 ≤ a, b, c ≤ 10000
- a ≤ b
Sample Input 1
5 14 80
Sample Output 1
3
Solution
import java.util.Scanner;
public class Main{
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int a = sc.nextInt();
int b = sc.nextInt();
int c = sc.nextInt();
int count = 0;
for (int i = a; i <= b; i++) {
if (c % i == 0) {
count++;
}
}
System.out.println(count);
}
}